D. Суммарная сумма

Найти сумму цифр числа не так сложно, но что, если чисел несколько?
Напишите программу для выполнения этого действия.

Формат ввода

В первой строке указано число N Во всех последующих N строках написано по одному числу.

Формат вывода:

Требуется вывести общую сумму цифр всех введённых чисел (кроме N).

Пример

Ввод

5
1
2
3
4
5

Вывод

15

Ввод

3
123
654
789

Вывод

45

Решение

Получаем количество чисел и далее в цикле раскладываем их на цифры, накапливая их сумму.

Задача немногим сложнее K. Цифровая сумма. Разница в наличии еще одного цикла.

Посмотреть код

Решение

Python
count = int(input())

summa = 0

for _ in range(count):
    number = int(input())
    while number > 0:
        summa += number % 10
        number //= 10

print(summa)
Подписаться
Уведомить о
guest
0 комментариев
Старые
Новые Популярные