K. Цифровая сумма

Иногда требуется манипулировать с цифрами чисел.
Одно из самых простых действий, которое можно совершить — найти сумму цифр числа. Напишите программу, чтобы выполнить это действие.

Формат ввода

Вводится одно натуральное число.

Формат вывода:

Требуется вывести одно натуральное число — сумму цифр исходного.

Пример

Ввод

12345

Вывод

15

Ввод

100500

Вывод

6

Решение

В этой задаче нам очень пригодится второй вариант разложения числа на цифры из задачи J. Детский сад — штаны на лямках. Если раскладывать число по этому алгоритму в цикле, то нам остается просто накопить значение суммы поучившихся цифр. Условием прекращения цикла является нулевое значение раскладываемого числа на одной из итераций.

Посмотреть код

Решение

Python
num = int(input())

summa = 0

while num > 0:
    summa += num % 10  # s = s + num % 10
    num //= 10  # num = num // 10

print(summa)
Подписаться
Уведомить о
guest
9 комментариев
Старые
Новые Популярные
Алексей
Алексей
14.06.2024 11:31

a = input(«»)
b = 0

for i in a:
    b += int(i)

print(b)

можно еще так сделать

Ромальдин
Ромальдин
11.07.2024 12:51

Можете обьяснить почему так я вообще не врубаюсь

Ромальдин
Ромальдин
11.07.2024 13:04

Можете объяснить 7ую строку?

Ильгиз
Ильгиз
24.10.2025 16:30

Доброго времени суток!). Я сделал следующим образом — код ниже. Но я не могу понять, почему Phyton просит присвоить значения к переменным n и z, разве по умолчанию он не присваивает 0-ое значение «пустым» переменным? И на сколько мой вариант кода «правильный» или «рабочий»?))

x = int(input())
n = 0
z = 0
while n != x:
  y = x % 10
  z += y
  x = x // 10
print(z)
Ильгиз
Ильгиз
Ответить на  Сергей Клочко
24.10.2025 23:39

Огромное спасибо за ответ!)