K. Простая задача 3.0

Вспомним, что простые числа — те натуральные числа, у которых два делителя: оно само и 1.
Напишите программу для определения количества простых чисел среди введённых.

Формат ввода

В первой строке записано число N Во всех последующих N строках — по одному числу.

Формат вывода:

Требуется вывести общее количество простых чисел среди введённых (кроме N).

Пример

Ввод

5
1
2
3
4
5

Вывод

3

Ввод

6
11
13
15
63
71
51

Вывод

3

Решение

Продолжение задач про простые числа N. Простая задача и R. Простая задача 2.0

По большому счету простое развитие второй из цепочки задач, во внешнем цикле перебираем введенные числа и в счетчике накапливаем количество простых числе, найденных с помощью алгоритмя из первых двух задач.

Посмотреть код

Решение

Python
count = int(input())

simple_counter = 0

for i in range(count):
    if (number := int(input())) > 1:
        simple = True
        divider = 2
        while divider <= int(number ** 0.5) and simple:
            if number % divider == 0:
                simple = False
            else:
                divider = divider + 1
        if simple is True:
            simple_counter = simple_counter + 1

print(simple_counter)
Подписаться
Уведомить о
guest
2 комментариев
Старые
Новые Популярные
Mazen
Mazen
06.08.2025 07:49

N = int(input())

primes = 0

for i in range(N):
    count = 0
    num = int(input())
    if num == 1:
        pass
    for j in range(2, num):

        if num % j != 0:
            count += 1
        else:
            break
    if count == num — 2:
        primes += 1
print(primes)

Ильгиз
Ильгиз
09.12.2025 11:15

Оставляю свой вариант решения этой задачки:

counter = int(input())
prime_numbers = 0
for i in range(counter):
  number = int(input())
  root_number = number ** 0.5
  if number > 3:
    for divisor in range(2, int(root_number + 1)):
      if number % divisor == 0:
        break
      elif divisor == int(root_number):
        prime_numbers += 1
  elif number == 2 or number == 3:
    prime_numbers += 1
print(prime_numbers)