N. Простая задача

Один из самых интересных видов чисел в математике — простые числа. Их объединяет то, что делятся они лишь на 1 и само себя. До сих пор их изучают учёные по всему миру. Также они применяются в вычислительной технике: с их помощью можно писать алгоритмы, чтобы шифровать данные. Давайте напишем программу, чтобы определять — простое перед нами число или нет.

Формат ввода

Вводится одно натуральное число.

Формат вывода:

Требуется вывести сообщение YES если число простое, иначе — NO.

Пример

Ввод

1

Вывод

NO

Ввод

67

Вывод

YES

Решение

Алгоритм нахождения простого числа достаточно прост.

Если число равно единице, то оно не простое.
в противном случае пробуем делить число на множители начиная от двух и пока не дойдем до самого числа. Если остаток от деления числа на такой делитель равен нулю, то это значит что число не простое.

Но на самом деле нет необходимости проверять абсолютно все числа из диапазона, например, достаточно легко прийти к выводу, что у числа не может быть делителя большего, чем само число делёное на два. Если подумать еще немного, то можно прийти к выводу, что у числа не может быть делителя большего чем корень из числа. Таким образом верхняя граница для проверки выглядит как корень из числа + 1. таким образом мы придумали алгоритм перебора делителей. Это не самый эффективный алгоритм, но для наших целей и уровня владения языком, это самый подходящий алгоритм.

Обратите внимание, что нам снова потребуется флаг, чтобы обозначить ситуацию получилось ли разделить число нацело, пока мы перебирали делители.

Посмотреть код

Решение

Python
num = int(input())

prime = True

if num <= 1:
    prime = False
else:
    for divisor in range(2, int(num**0.5 + 1)):
        if num % divisor == 0:
            prime = False
            break

if prime is True:
    print('YES')
else:
    print('NO')

Решение

Python
num = int(input())

divisor = 2
prime = True

if -1 <= num <= 1:
    prime = False
else:
    while divisor ** 2 <= num and prime is True:
        if num % divisor == 0:
            prime = False
        else:
            divisor = divisor + 1

if prime is True:
    print('YES')
else:
    print('NO')
Подписаться
Уведомить о
guest
7 комментариев
Старые
Новые Популярные
Алим
Алим
16.10.2024 21:21
ch=int(input())
d=1
k=0
while d<ch:
    if ch%d==0:
        k+=1
    else:
        k+=0
    d+=1
if k>1 or ch==1:
    print('NO')
else:
    print('YES')
Niko
Niko
04.01.2025 15:30

x = int(input())
counter = 2
yes_no = ‘YES’

if x == 1:
    yes_no = ‘NO’
else:
    for i in range(2, int(x ** 0.5 + 1)):
        if x % i == 0:
            counter += 1
            if counter > 2:
                yes_no = ‘NO’
print(yes_no)

Марат
Марат
14.01.2025 21:21

Зачем нужен divisor (в третьей строчке)?

Ильгиз
Ильгиз
29.10.2025 15:33

Доброго времени суток! Оставлю свой вариант решения.

number = int(input())
root_number = number ** 0.5
if number <= 1:
    print('NO')
else:
    for divisor in range(2, int(root_number + 1)):
        if number % divisor == 0:
            print('NO')
            break
        elif divisor == int(root_number):
            print('YES')
Ильгиз
Ильгиз
Ответить на  Ильгиз
09.12.2025 09:42

Решая задачку «Простая задача 3.0», обнаружил, что мой код выше не учитывает простые числа 2 и 3, но при этом яндекс принял этот код). Получается я нашёл «брешь»)). Исправил код дополнив его:

number = int(input())
root_number = number ** 0.5
if number <= 1:
    print('NO')
elif number > 3:
    for divisor in range(2, int(root_number + 1)):
        if number % divisor == 0:
            print('NO')
            break
        elif divisor == int(root_number):
            print('YES')
else:
    print('YES')