O. Числовая змейка 2.0

Воспитательнице вновь нужна программа, которая будет генерировать змейку из чисел. Напишите программу, которая строит числовую змейку требуемого размера.

Формат ввода

В первой строке записано число N — высота числового прямоугольника.
Во второй строке указано число M — ширина числового прямоугольника.

Формат вывода:

Нужно вывести сформированную числовую змейку требуемого размера.
Чтобы прямоугольник был красивым, каждый его столбец следует сделать одинаковой ширины.

Пример

Ввод

2
3

Вывод

1 4 5
2 3 6

Ввод

4
6

Вывод

 1  8  9 16 17 24
 2  7 10 15 18 23
 3  6 11 14 19 22
 4  5 12 13 20 21

Решение

Развитие наивного метода решения предыдущей задачи M. Числовой прямоугольник 2.0.

Алгоритмический метод решения требует знакомства со списками, поэтому мы его отпускаем и сконцентрируемся на наивном.

Решение отличается решения прошлой задачи только тем, что каждый четный столбец развернут снизу вверх. Нам придется учесть это в нашей формуле.

Посмотреть код

Решение

Python
# Наивный метод

height = int(input())
width = int(input())

ceil_width = len(str(width * height))

for row in range(height):
    for column in range(width):
        if column % 2 == 0:
            num = column * height + row + 1
        else:
            num = (column + 1) * height - row
        print(f'{num:>{ceil_width}}', end=' ')
    print()
Подписаться
Уведомить о
guest
0 комментариев
Старые
Новые Популярные
Межтекстовые Отзывы
Посмотреть все комментарии