M. Числовой прямоугольник 2.0

Давайте вновь поможем воспитательнице учить ребят числам. Напишите программу, которая строит числовой прямоугольник требуемого размера.

Формат ввода

В первой строке записано число N — высота числового прямоугольника.
Во второй строке указано число M — ширина числового прямоугольника.

Формат вывода:

Нужно вывести сформированный числовой прямоугольник требуемого размера.
Чтобы прямоугольник был красивым, каждый его столбец должен быть одинаковой ширины.

Пример

Ввод

2
3

Вывод

1 3 5
2 4 6

Ввод

4
6

Вывод

 1  5  9 13 17 21
 2  6 10 14 18 22
 3  7 11 15 19 23
 4  8 12 16 20 24

Решение

Как и в прошлой задаче, существует два способа решения этой задачи.

Наивный заключается в том, чтобы построить зависимость числа от его местоположения в квадрате.

Но можно схитрить, если заметить, что строка всегда начинается с номера строки, а расстояние между соседними элементами равно высоте таблицы.

Ниже представлены оба варианта решения задачи.

Посмотреть код

Решение

Python
# Наивный метод

height = int(input())
width = int(input())

cell_width = len(str(height * width))

for i in range(1, height + 1):
    for j in range(i, i + height * (width - 1) + 1, height):
        print(f'{j:>{cell_width}}', end=' ')
        if j == i + height * (width - 1):
            print()

Решение

Python
height = int(input())
width = int(input())

cell_width = len(str(width * height))

number = 1
for row in range(height):
    number = row + 1
    for _ in range(width):
        print(f'{number:>{cell_width}}', end=' ')
        number += height
    print()
Подписаться
Уведомить о
guest
4 комментариев
Старые
Новые Популярные
Станислав
Станислав
21.04.2025 12:27
n = int(input()) # высота
m = int(input()) # ширина
a = 0
b = 0

for i in range(1, n + 1):
    a = i
    for j in range(m):
        b = j
        number = a + (b * n)
        if number <= 9:
            print(end=' ')
        print(number, end=' ')
    print()
Ильгиз
Ильгиз
Ответить на  Станислав
12.12.2025 15:27

Неплохой вариант решения задачки, он мне понравился). Но, ваш код будет работать корректно в следующем виде:

n = int(input())
m = int(input())
cell_width = len(str(n * m))
for i in range(1, n + 1):
    for j in range(m):
        number = i + (j * n)
        print(f'{number:>{cell_width}}’, end=’ ‘)
    print()

Последний раз редактировалось 6 месяцев назад Ильгиз ем
Ильгиз
Ильгиз
12.12.2025 12:48

В первом варианте решения задачи можно обойтись без if, оставив только print(), но для этого необходимо print() переместить из вложенного цикла for в основной цикл for.

Ильгиз
Ильгиз
15.12.2025 14:22

Оставляю свой вариант решения этой задачки, основанный на информации с подсказки от яндекса. Но я его чуть чуть изменил для логического понимания:

num_row = int(input())
num_column = int(input())
max_num = num_row * num_column
cell_width = 0
while max_num != 0:
    cell_width += 1
    max_num //= 10
for row in range(1, num_row + 1):
    for column in range(1, num_column + 1):
        num = row + (column - 1) * num_row
        print(f'{num:>{cell_width}}', end=' ')
    print()