I. Большое число

Дети никак не успокоятся и продолжают «мучить» числа. Сейчас они хотят общими силами составить очень большое число. Каждый ребёнок называет число состоящее из цифр, которые он знает. Напишите программу, которая строит число, состоящее из максимальных цифр каждого ребёнка.

Формат ввода

В первой строке указано число N — количество детей в группе. В каждой из последующих N строк записано число.

Формат вывода:

Одно большое число.

Пример

Ввод

2
123
234

Вывод

34

Ввод

3
1234
7234
2323

Вывод

473

Решение

Задача не сильно отличается от предыдущей. Так же два цикла, только во внутреннем цикле мы будем не только раскладывать число на цифры, но и искать максимальное. А во внешнем мы будем накапливать результат.

Инициализируем результат нулем.
Принимаем количество детей.
Организуем цикл ввода числа и в нем инициализируем текущую максимальную цифру в значение, которое заведомо будет минимальным (0 или -1). В цикле сравниваем цифры числа с текущей максимальной. Как разделить число на отдельные цифры мы знаем из задачи K. Цифровая сумма.
Если цифра больше текущей максимальной, то запоминаем ее значение.
По окончании внутреннего цикла умножаем результат на 10 и прибавляем наш новый максимум.

Посмотреть код

Решение

Python
count = int(input())

result = 0

for _ in range(count):
    number = int(input())
    maximum = -1
    while number > 0:
        if number % 10 > maximum:
            maximum = number % 10
        number //= 10
    result = result * 10 + maximum

print(result)
Подписаться
Уведомить о
guest
1 Комментарий
Старые
Новые Популярные
Ильгиз
Ильгиз
03.12.2025 10:07

Оставляю свой вариант решения этой задачки при помощи функции str:

children = int(input())
number_big = »
for _ in range(children):
  number = int(input())
  number_str = »
  while number > 0:
    remainder = number % 10
    number //= 10
    number_str += str(remainder)
  number_big += max(number_str)
print(number_big)

Последний раз редактировалось 11 месяцев назад Ильгиз ем