L. Сильная цифра

Давайте попробуем выполнить ещё одно простое действие — найдём максимальную цифру числа.

Формат ввода

Вводится одно натуральное число.

Формат вывода:

Требуется вывести одно натуральное число — максимальную цифру исходного.

Пример

Ввод

12345

Вывод

5

Ввод

100500

Вывод

5

Решение

Задача очень похожа на прошлую, с той лишь разницей, что вместо суммы нам надо найти максимальную цифру.

Алгоритм поиска максимального значнеия довольно прост — инициализируем переменную в значение, которое однозначно окажется меньше или равно минимально возможному значению, после чего сравниваем его по очереди с каждым элементом (с каждой цифрой). Если новый элемент больше текущего максимума, то присваиваем максимуму новое значение.

Посмотреть код

Решение

Python
num = int(input())

maximum = -1

while num > 0:
    if num % 10 > maximum:
        maximum = num % 10
    num = num // 10

print(maximum)

Решение

Python
# пример использования функции max() для избежания явного сравнения

num = int(input())

maximum = -1

while num > 0:
    maximum = max(maximum, num % 10)
    num = num // 10

print(maximum)
Подписаться
Уведомить о
guest
0 комментариев
Старые
Новые Популярные