D. Считалочка 2.0

Дети продолжают запоминать цифры, а мы им помогать.
Нам вновь называют начало и конец последовательности чисел, а мы выводим их и числа между.

Формат ввода

Два числа, каждое с новой строки.

Формат вывода:

Все числа от начала до конца (включительно), записанные через пробел.

Пример

Ввод

1
10

Вывод

1 2 3 4 5 6 7 8 9 10

Ввод

3
-3

Вывод

3 2 1 0 -1 -2 -3

Решение

К предыдущей задаче добавили условие, усложняющее алгоритм. Теперь числа могут идти как в порядке возрастания, так и в порядке убывания.

Наивное решение предполагает создание двух циклов в зависимости от того какое число больше — первое или второе. Более продвинутое решение меняет параметры цикла и обходится одним циклом на все случаи.

Посмотреть код

Решение наивное

Python
start, stop = int(input()), int(input())

if stop >= start:
    for i in range(start, stop + 1):
        print(i, end=' ')
else:
    for i in range(start, stop - 1, -1):
        print(i, end=' ')

Решение продвинутое

Python
start, stop = int(input()), int(input())

step = 1

if stop < start:
    step = -1

for i in range(start, stop + step, step):
    print(i, end=' ')
    
Подписаться
Уведомить о
guest
0 комментариев
Старые
Новые Популярные