E. А роза упала на лапу Азора 6.0

Мы уже писали программы, которые определяли, а палиндром перед нами или нет.
Давайте теперь найдём все слова-палиндромы среди введённых строк.

Формат ввода

Вводятся слова.

Формат вывода

Список слов-палиндромов в алфавитном порядке без повторений.

Примечание

При проверке слов не обращайте внимание на регистр.

Пример

Ввод

Анна Боря Вова
Я последняя буква алфавита
Дед строит шалаш
Шалаш был хорош
Дед слышит топот
Ара залетел в шалаш

Вывод

Анна
Ара
Дед
Шалаш
Я
в
топот
шалаш

Решение

Продолжение задач про палиндромы. Единственная сложность — разбить поток ввода на отдельные слова, но мы в задачах B. Средний рост и D. Найдётся всё 2.0 уже изучили различные способы ввода, позволяющие получить все слова из потока ввода разными способами. Остается только подобрать тот, что больше по душе.

Посмотреть код

Решение

Python
from sys import stdin

words = []
strings = stdin.readlines()

for string in strings:
    for word in string.replace('\n', '').split():
        if word.upper() == word.upper()[::-1]:
            words.append(word)

print('\n'.join(sorted(set(words))))

Решение

Python
from sys import stdin

words = [word for word in stdin.read().split() if word]

result = [word for word in sorted(set(words)) if word.lower() == word[::-1].lower()]

print("\n".join(result))
Подписаться
Уведомить о
guest
0 комментариев
Старые
Новые Популярные