N. Спортивные гадания

Хорошо, спортсмены расставлены на старте. Вот только угадать финалистов практически невозможно. Давайте напишем программу, которая выводит список возможных победителей.

Формат ввода

В первой строке задано натуральное число N — количество спортсменов. В следующих N строках записаны имена спортсменов.

Формат вывода

Отсортированный по алфавиту список вариантов.
Имена в каждой строке выводить через запятую и пробел.

Пример

Ввод

3
Аня
Боря
Вова

Вывод

Аня, Боря, Вова
Аня, Вова, Боря
Боря, Аня, Вова
Боря, Вова, Аня
Вова, Аня, Боря
Вова, Боря, Аня

Ввод

4
Вова
Аня
Дима
Боря

Вывод

Аня, Боря, Вова
Аня, Боря, Дима
Аня, Вова, Боря
Аня, Вова, Дима
Аня, Дима, Боря
Аня, Дима, Вова
Боря, Аня, Вова
Боря, Аня, Дима
Боря, Вова, Аня
Боря, Вова, Дима
Боря, Дима, Аня
Боря, Дима, Вова
Вова, Аня, Боря
Вова, Аня, Дима
Вова, Боря, Аня
Вова, Боря, Дима
Вова, Дима, Аня
Вова, Дима, Боря
Дима, Аня, Боря
Дима, Аня, Вова
Дима, Боря, Аня
Дима, Боря, Вова
Дима, Вова, Аня
Дима, Вова, Боря

Решение

Фактически, полная копия предыдущей задачи с той лишь разницей, что нам надо выводить всевозможные комбинации, состоящие из трех элементов.

Посмотреть код

Решение

Python
from itertools import permutations
str = []

for _ in range(num := int(input())):
    str.append(input())

str.sort()

for pos in permutations(str, 3):
    print(', '.join(pos))
Подписаться
Уведомить о
guest
0 комментариев
Старые
Новые Популярные
Межтекстовые Отзывы
Посмотреть все комментарии