E. Список покупок

Поход в магазин часто вызывает проблемы. Если не подготовить список, можно уйти в магазин за хлебом, а вернуться с десятком пакетов. Напишите программу, которая собирает пожелания семьи (мамы, папы и дочки) в единый список.

Формат ввода

В трёх строках записаны желаемые продукты (через запятую и пробел).

Формат вывода

Отсортированный по алфавиту список продуктов с нумерацией.

Примечание

Помните, что итераторы можно применять к другим итераторам.

Пример

Ввод

картина, корзина, картонка
мыло, манка
молоко, хлеб, сыр

Вывод

1. картина
2. картонка
3. корзина
4. манка
5. молоко
6. мыло
7. сыр
8. хлеб

Решение

Для решения этой задачи нам потребуется функция chain() из модуля itertools.

Задача решается в два шага, с помощью chain(), объединяем три строки в одно множество, затем выводим отсортированый список покупок с помощью enumerate().

Посмотреть код

Решение

Python
from itertools import chain

lst = sorted(set(chain.from_iterable([input().split(", ") for _ in range(3)])))

for index, value in enumerate(lst, 1):
    print(f"{index}. {value}")
Подписаться
Уведомить о
guest
0 комментариев
Старые
Новые Популярные
Межтекстовые Отзывы
Посмотреть все комментарии