D. Словарная ёлка

Напишите программу, которая преобразует строку слов в ёлку как показано в примере.

Формат ввода

В одну строку через пробел вводятся слова разделенные пробелом.

Формат вывода

Несколько строк. В каждой следующей строке на одно слово больше.

Примечание

accumulate «складывает» не только числа.

Пример

Ввод

мама мыла раму

Вывод

мама
мама мыла
мама мыла раму

Ввод

картина корзина картонка

Вывод

картина
картина корзина
картина корзина картонка

Решение

Для решения этой задачи нам потребуется функция accumulate() из модуля itertools.

Посмотреть код

Решение

Python
from itertools import accumulate

for string in accumulate([word + ' ' for word in input().split()]):
    print(string)

Решение

Python
from itertools import accumulate

print('\n'.join(list(accumulate([word + ' ' for word in input().split()]))))
Подписаться
Уведомить о
guest
0 комментариев
Старые
Новые Популярные
Межтекстовые Отзывы
Посмотреть все комментарии