C. Рациональная считалочка

Напишите программу, которая производит счёт по заданным параметрам.

Формат ввода

В одну строку через пробел вводятся 3 рациональных числа — начало счета, конец и шаг.

Формат вывода

Последовательность чисел с заданными параметрами.

Пример

Ввод

3.2 6.4 0.8

Вывод

3.20
4.00
4.80
5.60
6.40

Ввод

3.14 10 1.57

Вывод

3.14
4.71
6.28
7.85
9.42

Решение

Для решения этой задачи нам потребуется функция count() из модуля itertools.

Функция count() очень похожа на range(), с той лишь разницей, что для нее нельзя задать конечное значение. В данном примере ее использование не дает никакого алгоритмического преимущества перед обычным циклом, однако позволяет ускорить программу на больших последовательностях.

Посмотреть код

Решение

Python
from itertools import count

start, stop, step = [float(x) for x in input().split()]

for num in count(start, step):
    if num >= stop:
        break
    print(f'{num:.2f}')
Подписаться
Уведомить о
guest
0 комментариев
Старые
Новые Популярные
Межтекстовые Отзывы
Посмотреть все комментарии