A. Автоматизация списка

Многим весьма часто приходится вести списки продуктов, дел и так далее.

Напишите программу, которая преобразует введённую строку в нумерованный список.

Формат ввода

Вводится одна строка.

Формат вывода

Требуется вывести нумерованный список, составленный из её слов.

Пример

Ввод

картина корзина картонка

Вывод

1. картина
2. корзина
3. картонка

Ввод

Аня Боря Вова

Вывод

1. Аня
2. Боря
3. Вова

Решение

Для решения этой задачи нам потребуется функция enumerate().Код который мы получим в процессе решения этой задачи один из самых широко используемых приемов, так как он позволяет совместить удобство работы с итерируемыми объектами методом перебора с одновременным получением индекса элемента.

В качестве параметра enumerate() принимает и итерируемый объект, и возвращает пару значений – индекс элемент. По-умолчанию, индекс начинается с нуля. для того, чтобы начать отсчет с другого значения, следует использовать параметр start

Посмотреть код

Решение

Python
for index, word in enumerate(input().split(), start=1):
    print(f'{index}. {word}')   

Решение

Python
print('\n'.join([f'{index}. {value}' for index, value in enumerate(input().split(), 1)]))
Подписаться
Уведомить о
guest
0 комментариев
Старые
Новые Популярные
Межтекстовые Отзывы
Посмотреть все комментарии