C. Зайка — 8

Продолжаем считать заек за окном поезда.

Формат ввода

В первой строке записано натуральное число N — количество выделенных придорожных местностей.
В каждой из N последующих строк записано описание придорожной местности.

Формат вывода:

Вывести все найденные объекты в придорожных местностях.

Пример

Ввод

3
березка елочка зайка волк березка
сосна зайка сосна елочка зайка медведь
сосна сосна сосна белочка сосна белочка

Вывод

сосна
березка
волк
елочка
медведь
белочка
зайка

Ввод

4
зайка березка
березка зайка
березка елочка березка
елочка елочка елочка

Вывод

березка
елочка
зайка

Решение

Получаем количество строк.
В цикле читаем строки и с помощью метода split() делим строку на отдельные слова, которые добавляем в множество.
Выводим объекты, которые находятся во множестве.

Посмотреть код

Решение

Python
items = set()

for _ in range(int(input())):
    string = input()
    items |= set(string.split())  # items = items | set(string.split())

for item in items:
    print(item)
Подписаться
Уведомить о
guest
1 Комментарий
Старые
Новые Популярные
Ильгиз
Ильгиз
02.10.2026 13:04

Мой вариант решения, просто с одним циклом и распаковкой через *.

string = set()
for location in range(int(input())):
  description = set(input().split())
  string = string | description
print(*string, sep='\n')