A. Символическая выжимка

Во многих промышленных задачах требуется понимать, из каких символов состоят данные. Напишите программу, чтобы по введённой строке она определяла, из каких символов та состоит.

Формат ввода

Вводится одна строка.

Формат вывода:

Требуется вывести все символы этой строки без повторений.
Порядок вывода не имеет значения.

Пример

Ввод

змееед

Вывод

здме

Ввод

велосипед

Вывод

исолвдеп

Решение

Простая задача на использование множеств. Если вспомнить, что множество можно построить из любого итерируемого (строки, списки, кортежи) объекта, а перевести множество в строку можно с помощью метода join(), то можно даже решить в одну строку.

Посмотреть код

Решение

Python
string = set(input())

for char in string:
    print(char, end='')

Решение

Python
# однострочный вариант

print(''.join(set(input())))
Подписаться
Уведомить о
guest
0 комментариев
Старые
Новые Популярные