B. Символическая разница

А ещё в промышленных задачах часто требуется находить общее среди данных, полученных из разных источников. Напишите программу, которая по двум строкам определяет их общие символы.

Формат ввода

Вводится две строки.

Формат вывода:

Требуется вывести все символы этой строки без повторений.
Порядок вывода не имеет значения.

Пример

Ввод

змееед
велосипед

Вывод

ед

Ввод

мама
папа

Вывод

а

Решение

Как и прошлая, эта задача предельно проста. Настолько, что тоже может быть решена в одну строку.

Достаточно преобразовать обе строки в множества и найти их пересечение.

Посмотреть код

Решение

Python
for char in (set(input()) & set(input())):
    print(char, end='')

Решение

Python
# однострочный вариант

print(''.join(set(input()).intersection(set(input()))))
Подписаться
Уведомить о
guest
0 комментариев
Старые
Новые Популярные