K. Однофамильцы

Начальник кадровой службы хочет выяснить, сколько мужчин-однофамильцев работает в организации. У него есть список фамилий, и на основании этого списка нужно вычислить количество фамилий, которые совпадают с другими

Формат ввода

В первой строке указывается количество мужчин — сотрудников организации (N).
Затем идут N строк с фамилиями этих сотрудников в произвольном порядке.

Формат вывода:

Количество однофамильцев в организации.

Пример

Ввод

6
Иванов
Петров
Сидоров
Петров
Иванов
Петров

Вывод

5

Ввод

3
Иванов
Петров
Сидоров

Вывод

0

Решение

Накапливаем фамилии в частотный словарь, затем считаем количество элементов, значение которых больше единицы.

Посмотреть код

Решение

Python
namesakes = {}

for _ in range(int(input())):
    name = input()
    namesakes[name] = namesakes.get(name, 0) + 1

count = 0
for name in namesakes:
    if namesakes[name] > 1:
        count += namesakes[name]

print(count)
Подписаться
Уведомить о
guest
0 комментариев
Старые
Новые Популярные
Межтекстовые Отзывы
Посмотреть все комментарии