D. Кашееды

Каждый воспитанник детского сада любит либо манную, либо овсяную, либо обе каши.
Давайте создадим программу, которая позволит воспитателю быстро выяснить, сколько детей любят обе каши.

Формат ввода

В первых двух строках указывается количество детей, любящих манную и овсяную каши (N и M).
Затем идут N строк — фамилии детей, которые любят манную кашу, и M строк с фамилиями детей, любящих овсяную кашу.
Гарантируется, что в группе нет однофамильцев.

Формат вывода:

Количество учеников, которые любят обе каши.
Если таких не окажется, в строке вывода нужно написать «Таких нет».

Пример

Ввод

3
2
Васильев
Петров
Васечкин
Иванов
Михайлов

Вывод

Таких нет

Ввод

3
3
Иванов
Петров
Васечкин
Иванов
Петров
Васечкин

Вывод

3

Решение

Считываем количество детей в каждом из списков, затем считываем список детей в два множества. Ищем пересечения множеств.

Посмотреть код

Решение

Python
list1size = int(input())
list2size = int(input())

list1 = set()
list2 = set()

for _ in range(list1size):
    list1.add(input())

for _ in range(list2size):
    list2.add(input())

if len(junction := (list1 & list2)) != 0:
    print(len(junction))
else:
    print('Таких нет')
Подписаться
Уведомить о
guest
0 комментариев
Старые
Новые Популярные