H. Зайка — 7

Вновь поищем заек за окном поезда.

Формат ввода

В первой строке записано натуральное число N — количество выделенных придорожных местностей.
В каждой из N последующих строк записано описание придорожной местности.

Формат вывода:

Для каждой строки нужно найти положение первого зайки.
Если в строке нет заек, то об этом нужно непременно сообщить.

Примечание

Для символов в строках используйте нумерацию с 1.

Пример

Ввод

3
березка елочка зайка волк березка
сосна зайка сосна елочка зайка медведь
сосна сосна сосна белочка сосна белочка

Вывод

16
7
Заек нет =(

Ввод

4
зайка березка
березка зайка
березка елочка березка
елочка елочка елочка

Вывод

1
9
Заек нет =(
Заек нет =(

Решение

Задача на использование методов find() или index().

В случае с find(): Перебираем строки, ищем заек, если find() вернул -1 — заек нет, если другое значение — увеличиваем его на единицу и выводим в качестве ответа.

В случае с index(): Перебираем строки, проверяем есть ли зайка в строке, если да, выводим результат, полученый с помощью index(), увеличенный на единицу. В противном случае пишем, что заек нет.

Посмотреть код

Решение

Python
# метод find

count = int(input())

for _ in range(count):
    position = input().find('зайка') + 1
    if position:
        print(position)
    else:
        print("Заек нет =(")

Решение

Python
count = int(input())

for _ in range(count):
    string = input()
    if 'зайка' in string:
        print(string.index('зайка') + 1)
    else:
        print("Заек нет =(")
Подписаться
Уведомить о
guest
2 комментариев
Старые
Новые Популярные
Алекс
Алекс
04.09.2024 14:39

bunnies not using…

greeting from go:-)

Последний раз редактировалось 1 год назад Алекс ем