F. Зайка — 6

Очередное путешествие родителей с детьми, очередная игра с поиском зверушек за окном.
Давайте поиграем и найдём заек.

Формат ввода

В первой строке записано натуральное число N — количество выделенных придорожных местностей.
В каждой из N последующих строк записано описание придорожной местности.

Формат вывода:

Количество заек.

Пример

Ввод

3
березка елочка зайка волк березка
сосна зайка сосна елочка зайка медведь
сосна сосна сосна белочка сосна белочка

Вывод

3

Ввод

4
зайка березка
березка зайка
березка елочка березка
елочка елочка елочка

Вывод

2

Решение

Эту задачу можно решить двумя способами – с помощью метода count() и с помощью самостоятельного перебора слов, полученных из строки с помощью метода split().

В первом случае просто используем метод count() для каждой строки, и накапливаем результат.

Во втором разбиваем строку на слова и с помощью цикла перебираем слова сравнивая их с искомым. Если слова совпали, увеличиваем счетчик заек. Второй метод позволяет закрепить тему вложенных циклов и научиться разбивать строку на слова c дальнейшим их перебором.

Посмотреть код

Решение

Python
# Использование count

count = int(input())

bunnies = 0
for _ in range(count):
    string = input()
    bunnies += string.count('зайка')

print(bunnies)

Решение

Python
# Использование split

count = int(input())

bunnies = 0
for _ in range(count):
    string = input().split()
    for word in string:
        if word == 'зайка':
            bunnies += 1

print(bunnies)
Подписаться
Уведомить о
guest
0 комментариев
Старые
Новые Популярные
Межтекстовые Отзывы
Посмотреть все комментарии