O. НОД 3.0

Местному НИИ в очередной раз нужно находить наибольший общий делитель (НОД) нескольких чисел.
Руководство института вернулось с этой задачей к нам.

Формат ввода

В единственной строке записывается последовательность натуральных чисел, разделённых пробелами.

Формат вывода:

Требуется вывести одно натуральное число — НОД всех данных чисел.

Пример

Ввод

12 42

Вывод

6

Ввод

102 39 768

Вывод

3

Решение

Продолжение задачи F. НОД 2.0

Отличие только в способе ввода данных

Посмотреть код

Решение

Python
string = input().split()

numbers = []

for digits in string:
    numbers.append(int(digits))

current_gcd = numbers[0]

for number in numbers[1:]:
    while number != 0:
        current_gcd, number = number, current_gcd % number

print(current_gcd)
Подписаться
Уведомить о
guest
0 комментариев
Старые
Новые Популярные
Межтекстовые Отзывы
Посмотреть все комментарии