K. Найдётся всё

Поиск информации — одна из основных нужд в современном мире.
Создайте программу, которая реализует маленький компонент поисковой системы.

Формат ввода

Вводится натуральное число N — количество страниц, среди которых требуется произвести поиск.
В каждой из последующих N строк записаны заголовки страниц.
В последней строке записан поисковый запрос.

Формат вывода:

Выводится один символ в нижнем регистре — наиболее часто встречающийся.

Примечания

Вывести все заголовки страниц, в которых присутствует поисковый запрос (регистр не имеет значения).
Порядок заголовков должен сохраниться.

Пример

Ввод

3
Яндекс выпустил задачник по программированию
На соревнованиях по программированию победил любитель питона
Как заказать Яндекс.Такси?!
яндекс

Вывод

Яндекс выпустил задачник по программированию
Как заказать Яндекс.Такси?!

Ввод

8
сериал шерлок смотреть онлайн
учебник питона
мемы
социальная сеть
упражнения по питону
кормовые мыши для питонов
ответы егэ скачать бесплатно
компьютерные мыши
питон

Вывод

учебник питона
упражнения по питону
кормовые мыши для питонов

Решение

Простая задача. Единственный новый момент — неявное требование сначала накопить данные, а потом их обработать. На самом деле это очень хорошая практика, если вы не стеснены в объемах памяти.

Считываем названия страниц в список.
Считываем запрос.
Перебираем список, если в названии статьи есть запрос — выводим название статьи. Не забываем при сравнении привести все в нижний регистр.

Посмотреть код

Решение

Python
count = int(input())

titles = []
for _ in range(count):
    titles.append(input())

query = input()

for title in titles:
    if query.lower() in title.lower():
        print(title)
Подписаться
Уведомить о
guest
0 комментариев
Старые
Новые Популярные