L. Меню питания

В детском саду ежедневно подают новую кашу на завтрак.
Каши чередуются в следующем порядке:

  • Манная;
  • Гречневая;
  • Пшённая;
  • Овсяная;
  • Рисовая.

Напишите программу, которая строит расписание каш на ближайшие дни.

Формат ввода

Вводится натуральное число N — количество дней.

Формат вывода:

Вывести список каш в порядке подачи.

Пример

Ввод

3

Вывод

Манная
Гречневая
Пшённая

Ввод

12

Вывод

Манная
Гречневая
Пшённая
Овсяная
Рисовая
Манная
Гречневая
Пшённая
Овсяная
Рисовая
Манная
Гречневая

Решение

Когда сталкиваешься с этой задачей сразу подмывает завести счетчик и дополнительную переменную которая будет сбрасываться в ноль по достижении значения равному размеру списка.

Но на самом деле нужно всего лишь вспомнить о чудесном операторе %, который с легкостью решает именно эту проблему.

Посмотреть код

Решение

Python
porridges = ['Манная', 'Гречневая', 'Пшённая', 'Овсяная', 'Рисовая']

days = int(input())
for day in range(days):
    print(porridges[day % len(porridges)])
Подписаться
Уведомить о
guest
1 Комментарий
Старые
Новые Популярные
Niko
Niko
18.02.2025 21:33

n = int(input())
k = [‘Манная’‘Гречневая’‘Пшённая’‘Овсяная’‘Рисовая’]
counter = 0

while counter < n:
    for i in k:
        if counter == n:
            break
        else:
            print(i)
            counter += 1