M. Массовое возведение в степень

Часто возникают трудности, когда нужно выполнить множество однообразных операций. В таких случаях люди желают упростить себе работу. Напишите программу, которая возводит в заданную степень все числа, что передали пользователи

Формат ввода

Вводится натуральное число N — количество чисел.
В каждой из последующих N строк записано по одному числу.
В последней строке записано натуральное число P — степень, в которую требуется возвести числа.

Формат вывода:

Последовательность чисел, являющихся ответом.

Пример

Ввод

3
2
3
4
3

Вывод

8
27
64

Ввод

5
222222
22222
2222
222
22
2

Вывод

49382617284
493817284
4937284
49284
484

Решение

Простая задача. Опять отрабатываем накопление данных с их последующей обработкой.

Посмотреть код

Решение

Python
count = int(input())
numbers = []

for _ in range(count):
    numbers.append(int(input()))

power = int(input())

for number in numbers:
    print(number ** power)
Подписаться
Уведомить о
guest
0 комментариев
Старые
Новые Популярные
Межтекстовые Отзывы
Посмотреть все комментарии