N. Массовое возведение в степень 2.0

Продолжим упрощать себе работу, минуя множество одинаковых операций.
Создадим новую программу, которая возводит в заданную степень все числа, переданные пользователем.

Формат ввода

В первой строке записана последовательность натуральных чисел, разделённых пробелами.
Во второй строке записано натуральное число P — степень, в которую требуется возвести числа.

Формат вывода:

Последовательность чисел, являющихся ответом.
Числа вывести в одну строку через пробел.

Пример

Ввод

2 3 4
3

Вывод

8
27
64

Ввод

8 27 64

Вывод

49382617284 493817284 4937284 49284 484

Решение

Слегка усложненный вариант, для отработки использования метода split() и преобразования типов данных

Считываем строку. Делим ее на отдельные последовательности и преобразуем их в целые числа.
После чего перебираем числа и выводим их в одну строку.

Посмотреть код

Решение

Python
numbers = []

string = input()
power = int(input())

numbers = string.split()

for number in numbers:
    print(int(number) ** power, end=' ')
Подписаться
Уведомить о
guest
2 комментариев
Старые
Новые Популярные
Niko
Niko
18.02.2025 20:32

x = list(map(intinput().split()))
st = int(input())
vivod = []

for i in x:
    j = i ** st
    vivod.append(j)
    
print(‘ ‘.join(map(str, vivod)))

Mazen
Mazen
10.08.2025 15:33

nums = map(intinput().split())

power = int(input())

for _ in nums:
    print(_**power, end=» «)