B. Кручу-верчу

Очень часто в текстовых редакторах требуется траспонировать (повернуть) текст.
К сожалению, в Python такая функция по умолчанию отсутствует. Давайте создадим программу, которая преобразует введённую стоку из горизонтальной записи в вертикальную.

Формат ввода

Одна строка.

Формат вывода:

Вертикальное представление введённой строки.

Пример

Ввод

Привет

Вывод

П
р
и
в
е
т

Ввод

Питон

Вывод

П
и
т
о
н

Решение

Простая задача на перебор значений в итерируемом объекте. может быть решена как через индексы, так и непосредственным перебором значений.

Посмотреть код

Решение

Python
# индексы

string = input()

for pos in range(len(string)):
    print(string[pos])

Решение

Python
# перебор значений

string = input()

for letter in string:
    print(letter)
Подписаться
Уведомить о
guest
0 комментариев
Старые
Новые Популярные
Межтекстовые Отзывы
Посмотреть все комментарии