A. Таблица умножения

Местная фабрика канцелярских товаров заказала у вас программу, которая генерирует таблицы умножения.
Давайте поддержим локального производителя!

Формат ввода

Вводится одно натуральное число — требуемый размер таблицы.

Формат вывода:

Таблица умножения заданного размера.

Пример

Ввод

3

Вывод

1 2 3
2 4 6
3 6 9

Ввод

5

Вывод

1 2 3 4 5
2 4 6 8 10
3 6 9 12 15
4 8 12 16 20
5 10 15 20 25

Решение

Простая задача на применение цикла for.

Получаем число.
Первый цикл задает строки, второй – столбцы в строках.
Внутри циклов выводим произведение счетчиков, с окончанием строки в виде пробела.
По окончании внутреннего цикла, используем пустой print(), чтобы перевести вывод на новую строку

Посмотреть код

Решение

Python
dim = int(input())

for i in range(dim):
    for j in range(dim):
        print((i + 1) * (j + 1), end=' ')
    print()

Решение

Python
dim = int(input()) + 1

for i in range(1, dim):
    for j in range(1, dim):
        print(i * j, end=' ')
    print()
Подписаться
Уведомить о
guest
2 комментариев
Старые
Новые Популярные
Межтекстовые Отзывы
Посмотреть все комментарии
Александр
Александр
03.09.2024 14:11

Вы пишете что задача на применение цикла while, а задача на for… И код на for