B. Не таблица умножения

Фабрика вернулась с новой задачкой — другим вариантом таблицы умножения. Она нужна в виде списка. Продолжим помогать местному бизнесу.

Формат ввода

Вводится одно натуральное число — требуемый размер «таблицы».

Формат вывода:

Не таблица умножения заданного размера.

Пример

Ввод

3

Вывод

1 * 1 = 1
2 * 1 = 2
3 * 1 = 3
1 * 2 = 2
2 * 2 = 4
3 * 2 = 6
1 * 3 = 3
2 * 3 = 6
3 * 3 = 9

Ввод

5

Вывод

1 * 1 = 1
2 * 1 = 2
3 * 1 = 3
4 * 1 = 4
5 * 1 = 5
1 * 2 = 2
2 * 2 = 4
3 * 2 = 6
4 * 2 = 8
5 * 2 = 10
1 * 3 = 3
2 * 3 = 6
3 * 3 = 9
4 * 3 = 12
5 * 3 = 15
1 * 4 = 4
2 * 4 = 8
3 * 4 = 12
4 * 4 = 16
5 * 4 = 20
1 * 5 = 5
2 * 5 = 10
3 * 5 = 15
4 * 5 = 20
5 * 5 = 25

Решение

С точки зрения программирования, задаче проще чем предыдущая. Единственное отличие – форматирование результата.

Посмотреть код

Решение

Python
dim = int(input())

for i in range(1, dim + 1):
    for j in range(1, dim + 1):
        print(f'{j} * {i} = {i * j}')
Подписаться
Уведомить о
guest
1 Комментарий
Старые
Новые Популярные
Межтекстовые Отзывы
Посмотреть все комментарии
Алим
Алим
22.10.2024 21:53
ch=int(input())
for i in range(1,ch+1):
    for x in range(1,ch+1):
        print(f'{i} * {x} = {i*x}')