На старт! Внимание! Марш!

По правилам велогонки, после квалификации каждый гонщик стартует с задержкой на секунду больше, чем у гонщика перед ним.
Первый гонщик стартует на счёт 3. Напишите программу, которая сможет автоматизировать старт всех гонщиков, участвующих в велогонке.

Формат ввода

Вводится одно натуральное число — количество участников велогонки.

Формат вывода:

Требуется вывести отсчёт.

Пример

Ввод

3

Вывод

До старта 3 секунд(ы)
До старта 2 секунд(ы)
До старта 1 секунд(ы)
Старт 1!!!
До старта 4 секунд(ы)
До старта 3 секунд(ы)
До старта 2 секунд(ы)
До старта 1 секунд(ы)
Старт 2!!!
До старта 5 секунд(ы)
До старта 4 секунд(ы)
До старта 3 секунд(ы)
До старта 2 секунд(ы)
До старта 1 секунд(ы)
Старт 3!!!

Ввод

4

Вывод

До старта 3 секунд(ы)
До старта 2 секунд(ы)
До старта 1 секунд(ы)
Старт 1!!!
До старта 4 секунд(ы)
До старта 3 секунд(ы)
До старта 2 секунд(ы)
До старта 1 секунд(ы)
Старт 2!!!
До старта 5 секунд(ы)
До старта 4 секунд(ы)
До старта 3 секунд(ы)
До старта 2 секунд(ы)
До старта 1 секунд(ы)
Старт 3!!!
До старта 6 секунд(ы)
До старта 5 секунд(ы)
До старта 4 секунд(ы)
До старта 3 секунд(ы)
До старта 2 секунд(ы)
До старта 1 секунд(ы)
Старт 4!!!

Решение

Основная сложность — справиться с увеличением задержки для каждого следующего участника.

Принимаем на вход количество участников гонки.
Задаем базовую задержку.
Заводим цикл по количеству участников в котором запускаем цикл, дающий обратный отсчет для каждого игрока.
по окончании внутреннего цикла вводим команду «Старт» и увеличиваем базовую задержку на единицу.

Посмотреть код

Решение

Python
count = int(input())

base_delay = 3

for number in range(1, count + 1):
    for delay in range(base_delay):
        print('До старта', base_delay - delay, 'секунд(ы)')
    print(f'Старт {number}!!!')
    base_delay += 1

Решение

Python
count = int(input())

base = 3

for number in range(count):
    for delay in range(base + number, 0, -1):
        print(f'До старта {delay} секунд(ы)')
    print(f'Старт {number + 1}!!!')
Подписаться
Уведомить о
guest
2 комментариев
Старые
Новые Популярные
Mazen
Mazen
05.08.2025 22:39
N = int(input())

for i in range(N):
    for j in range(3 + i, 0, -1):
        print(f'До старта {j} секунд(ы)')
        if j == 1:
            print(f'Старт {i + 1}!!!')
Ильгиз
Ильгиз
26.11.2025 14:05

Оставляю свой вариант решения этой задачки при помощи вложенного цикла while:

count = int(input())
countdown = initial = 3
for number in range(1, count + 1):
    while countdown != 0:
        print(f'До старта {countdown} секунд(ы)')
        countdown -= 1
    initial += 1
    countdown = initial
    print(f'Старт {number}!!!')