Q. А роза упала на лапу Азора 3.0

Вернёмся к палиндромам. Напишите программу, которая определяет количество палиндромов в переданном списке.

Формат ввода

В первой строке записано число N. Во всех последующих N строках указано по одному числу.

Формат вывода:

Требуется вывести общее количество палиндромов среди введённых чисел (кроме числа N).

Пример

Ввод

5
1
2
3
4
5

Вывод

5

Ввод

3
123
454
321

Вывод

1

Решение

Продолжение задачи P. А роза упала на лапу Азора 2.0.
Отличие только в дополнительным цикле и наличии счетчика палиндромов.

Посмотреть код

Решение

Python
count = 0

for _ in range(int(input())):
    number = int(input())
    original_num = number
    reversed_num = 0

    while number > 0:
        digit = number % 10
        reversed_num = reversed_num * 10 + digit
        number //= 10

    if original_num == reversed_num:
        count += 1
        
print(count)
Подписаться
Уведомить о
guest
2 комментариев
Старые
Новые Популярные
Mazen
Mazen
06.08.2025 23:23

count = int(input())

c = 0
for i in range(count):
    num = input()
    num_ = »
    for m in range(len(num)):
        num_ += num[-(m + 1)]
    if num_ == num:
        c += 1
print(c)

Ильгиз
Ильгиз
Ответить на  Mazen
18.12.2025 11:36

Решение с применением не пройденного материала…