O. Зайка — 4

Давайте вновь поиграем с детьми и поможем им найти заек.

Формат ввода

В первой строке записано натуральное число N — количество выделенных придорожных местностей. В каждой из N последующих строках — описание придорожной местности.

Формат вывода:

Количество строк, в которых есть зайка.

Пример

Ввод

3
березка елочка зайка волк березка
сосна сосна сосна елочка грибочки медведь
сосна сосна сосна белочка сосна белочка

Вывод

1

Ввод

4
зайка березка
березка зайка
березка елочка березка
елочка елочка елочка

Вывод

2

Решение

Перебираем строки и проверяем наличие в них заек с помощью оператора in. Если найден зайка, увеличиваем счетчик на единицу.

Посмотреть код

Решение

Python
places = int(input())

bunnies = 0

for i in range(places):
    nature = input()
    if 'зайка' in nature:
        bunnies += 1
print(bunnies)
Подписаться
Уведомить о
guest
0 комментариев
Старые
Новые Популярные