B. Зайка — 3

В задачнике ко второй лекции мы помогали детям искать зайца.
На этот раз мы будем искать и считать сразу нескольких зайчат.

Формат ввода

Вводятся строки, описывающие придорожную местность.
В конце поездки вводится «Приехали!»

Формат вывода:

Количество строк, в которых есть зайка.

Пример

Ввод

березка елочка зайка волк березка
сосна сосна сосна елочка грибочки медведь
сосна сосна сосна белочка сосна белочка
Приехали!

Вывод

1

Ввод

зайка березка
березка зайка
березка елочка березка
Приехали!

Вывод

2

Решение

Задача немногим сложнее предыдущей. Добавляется счетчик заек, встретившихся строках.

Посмотреть код

Решение

Python
count = 0

while (s := input()) != 'Приехали!':
    if 'зайка' in s:
        count += 1
print(count)
Подписаться
Уведомить о
guest
0 комментариев
Старые
Новые Популярные
Межтекстовые Отзывы
Посмотреть все комментарии