A. Раз, два, три! Ёлочка, гори!

В детском саду проводят новогодний утренник. Со знанием чисел и их порядком у детей пока есть небольшие проблемы, но цифру три знают все без исключения.

Напишите программу, которая зажигает Ёлочку, когда все дети прокричат «Три!»

Формат ввода

Вводятся крики детей.

Формат вывода:

Выводить «Режим ожидания…», пока дети не прокричат «Три!».
В конце вывести «Ёлочка, гори!»

Пример

Ввод

Раз!
Два!
Три!

Вывод

Режим ожидания...
Режим ожидания...
Ёлочка, гори!

Ввод

Десять!
Девять!
Раз!
Три!

Вывод

Режим ожидания...
Режим ожидания...
Режим ожидания...
Ёлочка, гори!

Решение

Простая задача на применение цикла while.

Основная сложность в том, что приходится или использовать моржовый оператор присвоения := или два input() – перед циклом и в самом цикле

Посмотреть код

Решение

Python
s = input()
while s != 'Три!':
    print('Режим ожидания...')
    s = input()
print('Ёлочка, гори!')

Решение c моржовым оператором

Python
while (s := input()) != 'Три!':
    print('Режим ожидания...')
print('Ёлочка, гори!')
Подписаться
Уведомить о
guest
1 Комментарий
Старые
Новые Популярные
Межтекстовые Отзывы
Посмотреть все комментарии
Алим
Алим
15.10.2024 23:47
while (sch:=input()!='Три!'):
    print('Режим ожидания...')
print('Ёлочка, гори!')