G. НОК

Спустя время НИИ потребовалось находить наименьшее общее кратное (НОК) двух чисел. К нам вновь обратились за помощью.

Формат ввода

Вводится два натуральных числа, каждое на своей строке.

Формат вывода:

Требуется вывести одно натуральное число — НОК двух данных чисел.

Пример

Ввод

12
42

Вывод

84

Ввод

512
625

Вывод

320000

Решение

Наименьшее общее кратное равно произведению чисел, деленному на их наименьший общий делитель.
Таким образом, нам нужно лишь слегка модифицировать решение из предыдущей задачи.

Посмотреть код

Решение

Python
a, b = a1, b1 = int(input()), int(input())

while a != 0:
    a, b = b % a, a

print(a1 * b1 // (a + b))

Решение

Python
a, b = int(input()), int(input())

product = a * b

while b != 0:
    a, b = b, a % b

print(product // a)

Решение

Python
# нестандартный алгоритм нахождения НОК

a, b = int(input()), int(input())

lcm = maximum = max(a, b)
minimum = min(a, b)

while lcm % minimum != 0:
    lcm += maximum
    
print(lcm)
Подписаться
Уведомить о
guest
0 комментариев
Старые
Новые Популярные