H. Излишняя автоматизация 2.0

А что будет, если вновь, как в первой главе, объединить два принципа — повторение и автоматизацию?

Формат ввода

В первой строке записана весьма полезная информация. Во второй натуральное число N — количество раз, которое её нужно повторить, чтобы она закрепилась.

Формат вывода:

N раз повторенная весьма полезная информация.

Пример

Ввод

2 + 2 = 4
3

Вывод

2 + 2 = 4
2 + 2 = 4
2 + 2 = 4

Ввод

Нельзя нажимать неизвестные кнопки!
4

Вывод

Нельзя нажимать неизвестные кнопки!
Нельзя нажимать неизвестные кнопки!
Нельзя нажимать неизвестные кнопки!
Нельзя нажимать неизвестные кнопки!

Решение

Простая задача на использование цикла for.
Обратите внимание на то, что мы используем символ подчеркивания _ вместо переменной цикла. Так делают, когда само значение переменной в теле цикло не важно, а важно лишь количество повтороений.

Посмотреть код

Решение

Python
info = input()
repeat = int(input())

for _ in range(repeat):
    print(info)
Подписаться
Уведомить о
guest
0 комментариев
Старые
Новые Популярные
Межтекстовые Отзывы
Посмотреть все комментарии