I. Факториал

Учёным срочно нужно ПО, которое находит факториал числа.

Формат ввода

Вводится одно неотрицательное число.

Формат вывода:

Требуется вывести одно натуральное число — факториал заданного числа.

Пример

Ввод

3

Вывод

6

Ввод

5

Вывод

120

Решение

Факториал – произведение всех чисел от единицы до искомого числа включительно. Факториал нуля равен единице.
Таким образом инициализируем переменную в который мы будем накапливать значение факториала единицей и в цикле умножаем его на следующее число последовательности чисел от единицы до нужного значения.

Посмотреть код

Решение

Python
num = int(input())

factorial = 1

for i in range(1, num + 1):
    factorial *= i

print(factorial)
Подписаться
Уведомить о
guest
2 комментариев
Старые
Новые Популярные
Межтекстовые Отзывы
Посмотреть все комментарии